Cómo actualizar la versión de Node js a 0.12.4 en Ubuntu

Quiero actualizar la versión Node JS en Ubuntu.

Probé muchos comandos, pero su versión aún es la más antigua, es decir v0.10.37

Lo intenté:

sudo npm install -gn sudo n install 0.12.4 sudo n use 0.12.4 

También probé con nvm pero ninguno de ellos funciona para mí. ¿Cómo puedo actualizar la versión de Node Js a 0.12.4?

Use npm para actualizar el nodo

Primero limpia el caché y prueba

 sudo npm cache clean -f sudo npm install -gn sudo n 0.12.4 

Luego cree un enlace simbólico (solo se necesita algunas veces, primero intente con estos tres comandos. Si no funciona, agregue esto).

Se actualizará a la versión 0.12.4 .

Podría ser suficiente con solo instalar el módulo n :

sudo npm install -gn

y luego simplemente ejecute:

sudo n 0.12.4

El truco es que puede que no se actualice en su sesión de terminal actual. Así que simplemente puede abrir una pestaña más en su terminal o simplemente otra terminal y verificar su versión de nodejs al:

node --version

Eso es todo, la salida será v0.12.4

El documento oficial del repository de nodejs apunta a esto: https://nodesource.com/blog/nodejs-v012-iojs-and-the-nodesource-linux-repositories#installing-node-js-v0-12

Sólo tienes que seguir y tendrás el 0.12.4.

Intenta ejecutar esto en la terminal:

 nvm install 5.10.1 nvm use 5.10.1 

La versión puede ser cambiada.

¡Aclamaciones!

Ejecute el siguiente comando para actualizar nodejs a 0.12.x

Anote el nuevo nombre del script de configuración para Node.js v0.12

curl -sL https://deb.nodesource.com/setup_0.12 | sudo bash

Luego instale con:

sudo apt-get install -y nodejs

Solo ignora la advertencia. Al ejecutar ambos comandos me funcionó en Ubuntu 14.04

En Ubuntu 16.04

No hay un comando especial o dedicado para actualizar la versión del nodo. La forma correcta de instalar o actualizar el nodo en ubuntu es:

1) descargue la distribución que desee del sitio oficial de nodejs , mueva el archivo a una ruta conocida

2) abra un terminal y ejecute:> sudo tar -C /usr/local --strip-components 1 -xzf "known path/name_of_the_distribution_file...gz

3) pruebe si todo está bien: abra un nuevo terminal y ejecute el node --version . Debería hacerse eco de la versión que descargó e instaló / actualizó.