Error de instalación iónica en windows 7

Seguí las instrucciones desde aquí para instalar ionic en windows7, pero recibí el error.

Otras versiones de utilidad instaladas actualmente son:

nodejs version 4.3.1 npm version 2.14.12 cordova version 6.0.0 

Cuando bash instalar el ionic obtengo el siguiente resultado

 C:\Users\pranav>npm install -g ionic npm WARN deprecated gulp-minify-css@0.3.13: Please use gulp-cssnano instead. npm WARN deprecated graceful-fs@3.0.8: graceful-fs version 3 and before will fail on newer node releases. Please update to graceful-fs@^4.0.0 as soon as possible. npm WARN deprecated npmconf@2.1.2: this package has been reintegrated into npm and is now out of date with respect to npm npm WARN deprecated lodash@1.0.2: lodash@ spawn-sync@1.0.15 postinstall C:\Users\pranav\node_modules\ew\node_modules\gulp-sass\node_modules\node-sass\node_modules\cross-spawn\node_modules\spawn-sync > node postinstall / node-sass@3.4.2 install C:\Users\pranav\node_modules\ew\node_modules\gulp-sass\node_modules\node-sass node scripts/install.js Binary downloaded and installed at C:\Users\pranav\node_modules\ew\node_modules\gulp-sass\node_modules\node-sass\vendor\win32-ia32-46\binding.node > node-sass@3.4.2 postinstall C:\Users\pranav\node_modules\ew\node_modules\gulp-sass\node_modules\node-sass > node scripts/build.js C:\Users\pranav\node_modules\ew\node_modules\gulp-sass\node_modules\node-sass\vendor\win32-ia32-46\binding.node exists. testing binary. Binary is fine; exiting. ew@1.1.1 C:\Users\pranav\node_modules\ew ├── gulp-rename@1.2.2 ├── gulp-concat@2.6.0 (concat-with-sourcemaps@1.0.4, through2@0.6.5, gulp-util@3.0.7) ├── gulp-minify-css@0.3.13 (memory-cache@0.0.5, vinyl-sourcemaps-apply@0.1.4, bufferstreams@0.0.2, through2@0.6.5, clean-css@3.0.10, gulp-util@3.0.7) ├── gulp@3.9.1 (interpret@1.0.0, pretty-hrtime@1.0.2, deprecated@0.0.1, archy@1.0.0, minimist@1.2.0, semver@4.3.6, tildify@1.1.2, v8flags@2.0.11, chalk@1.1.1, orchestrator@0.3.7, liftoff@2.2.0, vinyl-fs@0.3.14, gulp-util@3.0.7) └── gulp-sass@2.2.0 (object-assign@4.0.1, vinyl-sourcemaps-apply@0.2.1, through2@2.0.1, gulp-util@3.0.7, node-sass@3.4.2) 

Por favor, ayúdame a resolver este problema.

Asegúrate de descargar e instalar Git para Windows .

Para instalar Cordova, asegúrese de tener instalado Node.js , luego ejecute

  npm install -g cordova 

Usuarios de Windows que desarrollan para Android: querrás asegurarte de que tienes lo siguiente instalado y configurado.

NOTA: Cada vez que realice cambios en el PATH o en cualquier otra variable de entorno, deberá reiniciar o abrir una nueva pestaña en su progtwig shell para que el cambio de PATH tenga efecto.

Java JDK

Instale el Java JDK más reciente (NO solo el JRE).

A continuación, cree una variable de entorno para JAVA_HOME que apunte a la carpeta raíz donde se instaló el JDK de Java. Por lo tanto, si instaló el JDK en C: \ Archivos de progtwig \ Java \ jdk7, establezca JAVA_HOME para que sea esta ruta. Después de eso, agregue el directorio bin del JDK a la variable PATH también. Siguiendo el supuesto anterior, esto debería ser% JAVA_HOME% \ bin o la ruta completa C: \ Archivos de progtwig \ Java \ jdk7 \ bin

Hormiga apache

Para instalar Ant, descargue un zip desde aquí, extráigalo, mueva la primera carpeta del zip a un lugar seguro y actualice su PATH para incluir la carpeta bin en esa carpeta. Por ejemplo, si mueve la carpeta Ant a c: /, desearía agregar esto a su PATH: C: \ apache-ant-1.9.2 \ bin.

SDK de Android

Instalar el SDK de Android también es necesario. El SDK de Android le proporciona las bibliotecas API y las herramientas de desarrollador necesarias para crear, probar y depurar aplicaciones para Android.

Cordova requiere que se establezca la variable de entorno ANDROID_HOME. Esto debería apuntar al directorio [ANDROID_SDK_DIR] \ android-sdk (por ejemplo, c: \ android \ android-sdk).

A continuación, actualice su RUTA para incluir la carpeta herramientas / y plataforma-herramientas / en esa carpeta. Por lo tanto, utilizando ANDROID_HOME, agregará tanto% ANDROID_HOME% \ tools como% ANDROID_HOME% \ platform-tools.

Instalar Ionic

 npm install -g ionic 

Espero que esto te ayudará !