Recomstackción de dependencias de nodo usando otra versión de nodo

Quiero instalar algunas dependencias y en este caso instalar node-pty. Pero cuando lo ejecuto me dan este error:

Error: El módulo ‘/home/dev/Documents/project/node_web_kit/node_modules/node-pty/build/Release/pty.node’ fue comstackdo contra una versión diferente de Node.js usando NODE_MODULE_VERSION 46. Esta versión de Node.js requiere NODE_MODULE_VERSION 51. Intente volver a comstackr o reinstalar

alguna solucion?

La forma más sencilla de estar seguro es simplemente eliminar node_modules y volver a ejecutar npm i desde cero, de esa forma todos los módulos se configurarán definitivamente para la nueva versión de Node.

Reconstruye el módulo node-pty usando:

npm rebuild node-pty --update-binary