El paquete web falla en @ font-face

Tengo un problema al utilizar Webpack con FontAwesome. Aquí están mis cargadores:

module: { loaders: [ { test: /(\.js$)|(\.jsx$)/, exclude: /node_modules/, loader: 'babel-loader' }, { test: /(\.jade$)/, exclude: /node_modules/, loader: 'jade-loader' }, { test: /(\.css$)/, exclude: /node_modules/, loaders: ['style-loader', 'css-loader', 'postcss-loader'] }, { test: /(\.styl$)/, exclude: /node_modules/, loaders: ['style-loader', 'css-loader', 'stylus-loader'] }, { test: /\.(jpe|jpg|woff|woff2|eot|ttf|svg)(\?.*$|$)/, exclude: /node_modules/, loader: 'url-loader?importLoaders=1&limit=100000' }, { test: /\.jsx$/, exclude: /node_modules/, loader: 'react-hot-loader' } ], } 

Y aquí está el error que estoy recibiendo:

 ERROR in ./~/font-awesome/css/font-awesome.css Module parse failed: /Users/Username/Documents/Project/sub-project/node_modules/font-awesome/css/font-awesome.css Line 7: Unexpected token ILLEGAL You may need an appropriate loader to handle this file type. | /* FONT PATH | * -------------------------- */ | @font-face { | font-family: 'FontAwesome'; | src: url('../fonts/fontawesome-webfont.eot?v=4.4.0'); @ ./client/app.js 83:0-60 

¿Alguien más ha experimentado este problema y ha encontrado una solución? Cualquier sugerencia sería muy apreciada. Gracias.

Error tonto Se eliminó la exclusión de mi cargador css y se puso a trabajar.

 { test: /(\.css$)/, loaders: ['style-loader', 'css-loader', 'postcss-loader'] } 
Intereting Posts